Blog

Instalação da API NFS-e no Maker 2.x/3.x

Dependências

As APIs da L2 dependem de sua biblioteca base (l2s-core.jar). Antes de
instalar qualquer API é necessário baixar e instalar a versão mais
recente dessa biblioteca.

Maker 2.x ou 3.x

  1. Acesso o sistema onde deseja adicionar as funções de NFS-e;
  2. Feche o editor de fluxos, e o cadastro de funções se estiverem abertos;
  3. Importe o arquivo ‘l2s-api-nfse-v*.frz’;
  4. Abra o edito de fluxos e procure pela nova categoria ‘L2S – NFS-e’;
  5. Pronto! Basta instalar no Webrun e usar as novas funções.

Webrun 2.x ou 3.x

  1. Copie o conteúdo da pasta Maker.Commons para a pasta
    [WEBRUN]\systems\Maker.Commons (crie-a se não existir);
  2. Reinicie o Tomcat do Webrun;
  3. Acesse o sistema (1a vez);
  4. Reinicie novamente o Tomcat do Webrun;
  5. Acesse o sistema novamente;
  6. Pronto! As bibliotecas estão instaladas.

VERSÃO DE AVALIAÇÃO

  • A versão de avaliação apresenta uma ou mais das seguintes limitações:
    • Somente se conecta ao ambiente de homologação;
    • Não retorna alguns XMLs.

Leave a comment